TFW8bit composite mod board

Discussions about Sinclair ZX80 and ZX81 Hardware
Lardo Boffin
Posts: 1300
Joined: Sat Nov 26, 2016 2:42 am

TFW8bit composite mod board

Post by Lardo Boffin »

As I have run out of ZX8-CCBs and it looks like they are not coming up for sale any time soon I thought I would try a board from The Future Was 8 Bit. I have fitted a few of these to Atari 2600 and they produce great results. It shows them as being compatible with the ZX81 so I fitted a spare one I had as per the linked instructions (http://blog.tynemouthsoftware.co.uk/201 ... n.html?m=1).

I got the following:
086B72ED-B1BA-4169-988D-D0909A99B753.jpeg
The K moves down the screen in a fairly stable pattern and the horizontal lines follow it flashing on and off. This is my most forgiving TV.

Fitted:
DDAB7085-D2B9-4E1B-9BB7-4A3AE27B6C09.jpeg

Its a 2C210E ULA.

Anything obvious I have got wrong?

(Please come back to us PokeMon!!!)
ZX80
ZX81 iss 1 (bugged ROM, kludge fix, normal, rebuilt)
Iss 3 ZXVid
TS 1000 iss 3, ZXPand AY, ZX8-CCB, ZX-KDLX & ChromaSCART
TS 1500 & 2000
Spectrum 16k (iss 1 s/n 862)
Spectrum 48ks plus a DIVMMC future and SPECTRA
Spectrum +2a
User avatar
mrtinb
Posts: 1259
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: TFW8bit composite mod board

Post by mrtinb »

I had to remove the modulator to get a good picture on my ZX81.
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube
Lardo Boffin
Posts: 1300
Joined: Sat Nov 26, 2016 2:42 am

Re: TFW8bit composite mod board

Post by Lardo Boffin »

I did wonder about fitting it separately to the RF modulator but I think the modulator is electrically isolated from the board now - the video in goes straight to the comp board as does the +5V. The only part of the mod in use now is the case which acts as ground.
ZX80
ZX81 iss 1 (bugged ROM, kludge fix, normal, rebuilt)
Iss 3 ZXVid
TS 1000 iss 3, ZXPand AY, ZX8-CCB, ZX-KDLX & ChromaSCART
TS 1500 & 2000
Spectrum 16k (iss 1 s/n 862)
Spectrum 48ks plus a DIVMMC future and SPECTRA
Spectrum +2a
User avatar
1024MAK
Posts: 3168
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: TFW8bit composite mod board

Post by 1024MAK »

What was the RF output like before the mod.?

Mark
Lardo Boffin
Posts: 1300
Joined: Sat Nov 26, 2016 2:42 am

Re: TFW8bit composite mod board

Post by Lardo Boffin »

It was ok. Not brilliant but not jumping around the place.
ZX80
ZX81 iss 1 (bugged ROM, kludge fix, normal, rebuilt)
Iss 3 ZXVid
TS 1000 iss 3, ZXPand AY, ZX8-CCB, ZX-KDLX & ChromaSCART
TS 1500 & 2000
Spectrum 16k (iss 1 s/n 862)
Spectrum 48ks plus a DIVMMC future and SPECTRA
Spectrum +2a
bola_dor
Posts: 187
Joined: Wed Oct 02, 2019 5:32 am

Re: TFW8bit composite mod board

Post by bola_dor »

Make sure that nothing else is still connected to the video out center pin..
I had this TS1500 that drove me krazy because this coneccion from behind
20200728_011215.jpg
ZX80, CZ1000, CZ1500, CZ2000, CZ1000Plus, CZ Spectrum, Sinclair QL.
User avatar
1024MAK
Posts: 3168
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: TFW8bit composite mod board

Post by 1024MAK »

Well a vertically rolling picture normally means that the display sync. circuitry can’t lock on to the vertical (field) sync. signal.

So it’s possible that the problem is simply the voltage level from the ZX81 being too high. You could try fitting one or two 1N4148 diodes between the ZX81 and the video input to the composite mod board. If the diodes come in a package that has a black band at one end, the end with the black band is the cathode, wire that end to the composite mod board. if one diode does not work, wire a second one in series with the first. Same orientation.

Alternatively if you don’t have any suitable diodes (in fact any small signal silicon diode will do), instead use a multimeter to see what voltage you get at the input to the composite mod board, also what voltage you get at the output.

Mark
Lardo Boffin
Posts: 1300
Joined: Sat Nov 26, 2016 2:42 am

Re: TFW8bit composite mod board

Post by Lardo Boffin »

Thanks Mark. I probably don’t have any diodes but can certainly get some if required.

Will get the multimeter out tomorrow and get measuring.

Edit - just remembered I am part way through fitting 16K internal RAM so will have to wait until that is finished.
ZX80
ZX81 iss 1 (bugged ROM, kludge fix, normal, rebuilt)
Iss 3 ZXVid
TS 1000 iss 3, ZXPand AY, ZX8-CCB, ZX-KDLX & ChromaSCART
TS 1500 & 2000
Spectrum 16k (iss 1 s/n 862)
Spectrum 48ks plus a DIVMMC future and SPECTRA
Spectrum +2a
Lardo Boffin
Posts: 1300
Joined: Sat Nov 26, 2016 2:42 am

Re: TFW8bit composite mod board

Post by Lardo Boffin »

The 5V DC in is getting about 4.95V.

The video in is showing about 3.5V.

The video out is showing about 2.85V.

And here it is working on a far more picky TV. Go figure. I will test my other TV to make sure it is working ok!

DD1F36FA-9C55-42FB-9452-0EE1EA3840B7.jpeg
ZX80
ZX81 iss 1 (bugged ROM, kludge fix, normal, rebuilt)
Iss 3 ZXVid
TS 1000 iss 3, ZXPand AY, ZX8-CCB, ZX-KDLX & ChromaSCART
TS 1500 & 2000
Spectrum 16k (iss 1 s/n 862)
Spectrum 48ks plus a DIVMMC future and SPECTRA
Spectrum +2a
Lardo Boffin
Posts: 1300
Joined: Sat Nov 26, 2016 2:42 am

Re: TFW8bit composite mod board

Post by Lardo Boffin »

But then on the big TV in the living room...

Very washed out and pale.

9D464698-3AF7-48A1-8874-C7B7FD87089B.jpeg

Clearly this is not producing a good enough picture in this zeddy. I may try it in another next week and see if I get the same result.
ZX80
ZX81 iss 1 (bugged ROM, kludge fix, normal, rebuilt)
Iss 3 ZXVid
TS 1000 iss 3, ZXPand AY, ZX8-CCB, ZX-KDLX & ChromaSCART
TS 1500 & 2000
Spectrum 16k (iss 1 s/n 862)
Spectrum 48ks plus a DIVMMC future and SPECTRA
Spectrum +2a
Post Reply