EightyOne Test Build

Emulator and emulator development specific topics
MikeW
Posts: 66
Joined: Tue May 29, 2012 10:56 pm

EightyOne Test Build

Post by MikeW »

I've put together a test build of EightyOne which (hopefully) should fix a fair few sound related issues, along with probably creating even more.

Give it a go if you want...

https://drive.google.com/file/d/1jbTKSO ... sp=sharing

And let me know if it works...

Mike
REX LIES IN WAIT
Moggy
Posts: 2504
Joined: Wed Jun 18, 2008 2:00 pm

Re: EightyOne Test Build

Post by Moggy »

Unfortunately all the music programs tracker etc rely on ZXpand capability which seems absent so whilst the programs will load the tunes won't.
MikeW
Posts: 66
Joined: Tue May 29, 2012 10:56 pm

Re: EightyOne Test Build

Post by MikeW »

Hmmm.

I don't think I've changed anything to do with ZXPand. Are you saying the emulation options are missing, or it's not making sound. Could you send me some examples, since I don't have any?

Mike
REX LIES IN WAIT
SM7I
Posts: 10
Joined: Fri Dec 06, 2019 11:13 am

Re: EightyOne Test Build

Post by SM7I »

Please update the zxpand+ firmware to latest as well. Latest is Tomte.
MikeW
Posts: 66
Joined: Tue May 29, 2012 10:56 pm

Re: EightyOne Test Build

Post by MikeW »

SM7I wrote: Mon Jul 26, 2021 8:04 pm Please update the zxpand+ firmware to latest as well. Latest is Tomte.
When/if I do a release, I'll try to update any required firmware/roms... my list now includes

ZXpand firmware
H4th ROM

I found a small bug in the ZXPand emulation which probably only came to light because I've rewritten half the emulation loop of the emulator. I've uploaded another test here:

https://drive.google.com/file/d/1NAiijG ... sp=sharing

Mike
REX LIES IN WAIT
Moggy
Posts: 2504
Joined: Wed Jun 18, 2008 2:00 pm

Re: EightyOne Test Build

Post by Moggy »

Finally got it going after colossal mix ups on my part(don't ask)


I wouldn't bother upping the ZXpand firmware to TOMTE which only beefed up some of the hardware serial comm' functions and is also used with a new unreleased version of the current MIDI player (still being worked on sporadically) and I'm not sure it would work with an emulator anyway.

As for the sound I'm pleased to say the Tracker and STC player work well enough (not tried PT3 player but cannot see a problem.)

Whilst everything is now in tune without the horrible grunts and wheezes etc and is pitched correctly for the ZX81(not tried speccy AY) The tones are not quite right in their actual sound especially drums.
Could make short example recording if pushed, but not sure of file size limit here.

This will be ok for non musicians and games players who just want to listen to something going blip blip or playing tunes in the background. For myself who has a ton of semi composed stuff via the tracker and has created samples to sound a certain way then it sounds odd so unusable but as I'm the only one using the tracker (now that Yerz is wed and out of the picture) who cares. I only mention it because you asked for an opinion on it.

Also unless my ears mistake me,the AY is in mono which I know is is emulating the real Zonx in that regard but all players and trackers are stereo in their conception and use, albeit crudely mixed stereo and most emulators now seem to follow that concept .

Other than that great work Mike and good therapy too no doubt. :D
MikeW
Posts: 66
Joined: Tue May 29, 2012 10:56 pm

Re: EightyOne Test Build

Post by MikeW »

Thanks for the feed back.

Yes, at the moment it is mono, but that'll change now I know the code actually works on other machines than my own. As to the sound produced, I haven't (shouldn't have, at least) actually changed the AY emulation. My update should only affects the way we handle the sound output, DirectX-wise. The emulation now sounds like it originally should have. Regarding the WAY it sounds - that's another matter.

I will take a look at the AY code at some point, but that is down the list of things to do I'm afraid...

Mike
REX LIES IN WAIT
Moggy
Posts: 2504
Joined: Wed Jun 18, 2008 2:00 pm

Re: EightyOne Test Build

Post by Moggy »

Understood Mike.

To be honest the only accurately sounding AY I have heard in emulation for the ZX81 is that used by SZ-81.
I don't know if there could be any pointers there insofar as how the tone of the thing is achieved.

Please understand I'm not very technically minded, baby steps and all that.
User avatar
BarryN
Posts: 106
Joined: Thu Nov 09, 2017 11:34 pm

Re: EightyOne Test Build

Post by BarryN »

Moggy wrote: Mon Jul 26, 2021 11:42 pm Understood Mike.

To be honest the only accurately sounding AY I have heard in emulation for the ZX81 is that used by SZ-81.
I don't know if there could be any pointers there insofar as how the tone of the thing is achieved.

Please understand I'm not very technically minded, baby steps and all that.
Glad to hear you think SZ81 sounds reasonably correct. I have made some contributions to that emulator.
MikeW
Posts: 66
Joined: Tue May 29, 2012 10:56 pm

Re: EightyOne Test Build

Post by MikeW »

Moggy wrote: Mon Jul 26, 2021 11:42 pm Understood Mike.

To be honest the only accurately sounding AY I have heard in emulation for the ZX81 is that used by SZ-81.
I don't know if there could be any pointers there insofar as how the tone of the thing is achieved.

Please understand I'm not very technically minded, baby steps and all that.
That's interesting. I've just had a look at the source for SZ81 and its AY code is derived from the same place as EO - probably just a version several years newer lol. I think it'd almost be just a case of dropping in the newer code with a few small modifications...

{EDIT)

Hmmm, I don't know how much of a difference it makes, but EO uses a 22050Hz sample rate whereas SZ81 used 32000Hz - could it be that simple...
REX LIES IN WAIT
Post Reply