Page 3 of 3

Re: ZXPAND and Lambda 8300?

Posted: Sun Apr 29, 2018 7:04 pm
by dr beep
mrtinb wrote:
Sun Apr 29, 2018 2:02 pm
dr beep wrote:
Sun Apr 29, 2018 11:32 am
Ok...

3 changes in ROM.

#0039/#003A becomes JR NZ,SCANLINE
#003B is NOP , due to absolute jump to address of scanline, stays NOP

#0046 1 tstate too much.... so this becomes NOP
You are hereby officially declared: The Master that Knows ZX81 ROM by Heart in Sleep.

It works great.

(The 1st line looks tricky though.)

Image
First screen had the same error, so this has a different cause.

Re: ZXPAND and Lambda 8300?

Posted: Sun Apr 29, 2018 8:58 pm
by dr beep
First line is called from ROM and not set by intrupt, so there must be the fault.

Re: ZXPAND and Lambda 8300?

Posted: Sun Apr 29, 2018 9:38 pm
by mrtinb
Changing 1901 to 1909 fixed the first line.

Thank you again Johan!

I have sticked with the regular ZXpand ROM i the ZXpand, so it works with ZX81.

Then I have replaced the Lambda 8300 ROM with the ZXpand ROM modified for Lambda 8300.

So as you can see in this video I start out with garbled display, and type CONFIG "X" to disable ZXpand ROM. Then the internal ZXpand modified ROM kicks in and the display is great!

https://youtu.be/OR64TxXFJ3w

Image

Re: ZXPAND and Lambda 8300?

Posted: Mon Apr 30, 2018 10:16 am
by mrtinb
Thank you olofsen, nollkolltroll and dr beep for all your feedback. It's very nice that my Lambda 8300 now can load software. :mrgreen:

Re: ZXPAND and Lambda 8300?

Posted: Mon Apr 30, 2018 11:21 am
by dr beep
mrtinb wrote:
Sun Apr 29, 2018 9:38 pm
Changing 1901 to 1909 fixed the first line.

Thank you again Johan!

I have sticked with the regular ZXpand ROM i the ZXpand, so it works with ZX81.

Then I have replaced the Lambda 8300 ROM with the ZXpand ROM modified for Lambda 8300.

So as you can see in this video I start out with garbled display, and type CONFIG "X" to disable ZXpand ROM. Then the internal ZXpand modified ROM kicks in and the display is great!

https://youtu.be/OR64TxXFJ3w

Image

You can shift the display to left by altering the LD A, below the LD BC. Increase to shift to left.

Re: ZXPAND and Lambda 8300?

Posted: Mon Apr 30, 2018 11:34 am
by mrtinb
dr beep wrote:
Mon Apr 30, 2018 11:21 am
You can shift the display to left by altering the LD A, below the LD BC. Increase to shift to left.
Thank you. I planned to do that. I just didn't get that far last night.

Re: ZXPAND and Lambda 8300?

Posted: Wed May 02, 2018 11:23 pm
by mrtinb
After using it for a couple of days I can with sadness report: It’s quite unstable.

Some programs triggers a state where random chars show up on the screen. Specially ZXpand Commander triggers this state. Zxokoen from Andre*** does it as well.

I figured out that saved programs are blank.

I’ll use the system for running Hi-Z which requires M1NOT which this system has. All other stuff I need to use the stable ZX81.

Maybe some day I’ll get some storage that works better with Lambda 8300.

Re: ZXPAND and Lambda 8300?

Posted: Tue May 15, 2018 2:03 pm
by mrtinb
Conclusion: It works for LOAD, but not for SAVE.

Re: ZXPAND and Lambda 8300?

Posted: Tue May 15, 2018 9:00 pm
by dr beep
So we need to check out why SAVE doesn't work.