Search found 25 matches

by Kahenraz
Mon Jul 27, 2020 5:44 am
Forum: Hardware
Topic: No video output from my TS1500
Replies: 15
Views: 4326

Re: No video output from my TS1500

There is no video output at all. I tried switching channels but the TV remains blue (no signal). The display from my TS1000 units work fine on this TV.
by Kahenraz
Sun Jul 26, 2020 6:06 pm
Forum: Hardware
Topic: No video output from my TS1500
Replies: 15
Views: 4326

No video output from my TS1500

This is my only TS1500 so I don't have another set of chips to swap in. It never worked upon receipt. It appeared to be like-new cosmetically and expected to be lightly used. The internals have several bodges and a lot of flux around a large chip (probably from the factory). It's suspected to have b...
by Kahenraz
Sun Jul 26, 2020 5:55 pm
Forum: Hardware
Topic: Photos of my TS1500
Replies: 3
Views: 842

Re: Photos of my TS1000

Crystal is "secured" with double-sided tape that is barely attached to a capacitor. I pressed it down for the photo but the adhesive doesn't stick and it pops back up: IMG_20200725_135614.jpg Little wires on this part soldered directly into the board. Cool: IMG_20200725_135727.jpg Also. This unit do...
by Kahenraz
Sun Jul 26, 2020 5:52 pm
Forum: Hardware
Topic: Photos of my TS1500
Replies: 3
Views: 842

Photos of my TS1500

I received a Timex Sinclair 1000 that needed its keyboard matrix replaced. I snapped a few pictures of the terrible innards of my unit to share. Internal board overview: IMG_20200725_135842.jpg Nasty flux all around this chip. Probably drag-soldered the pins: IMG_20200725_135805.jpg Heat from a sold...
by Kahenraz
Sun Feb 23, 2020 7:34 pm
Forum: Hardware
Topic: How to perform a Timex Sinclair 1000 internal memory upgrade?
Replies: 11
Views: 7152

Re: How to perform a Timex Sinclair 1000 internal memory upgrade?

I am interested in both WRX for high-res as well as UDG.

Battery backed ram sounds interesting, and I do have some tiny LiPo batteries which might be perfect.

I ordered some 32k SRAM chips over a month ago from China. Still waiting for them to slow-boat over here. Zzzz.
by Kahenraz
Sun Feb 23, 2020 4:05 am
Forum: ZX Spectrum Lounge
Topic: Photo of my TC-2048
Replies: 9
Views: 14356

Re: Photo of my TC-2048

Tested it today and everything works great except for the TV output (composite monitor output works fine). I'm very happy with the computer as it is. The seller was very accommodating and helpful. Are there any use cases where the TV output would be desirable? I can't think of any, other than actual...
by Kahenraz
Tue Feb 11, 2020 11:58 am
Forum: ZX Spectrum Lounge
Topic: Photo of my TC-2048
Replies: 9
Views: 14356

Photo of my TC-2048

Had this beautiful item shipped in from Portugal. Gave it a good cleaning before setting it up for a photo.

Forgot to buy a power supply so it's just sitting pretty here until then.
by Kahenraz
Tue Feb 11, 2020 10:48 am
Forum: Emulators
Topic: EightyOne ZX81 emulator does not have a 56kB RAM option?
Replies: 4
Views: 8422

Re: EightyOne ZX81 emulator does not have a 56kB RAM option?

What is the relevance of this as an exclusive option?
by Kahenraz
Tue Feb 11, 2020 10:46 am
Forum: Emulators
Topic: Can this game be played on EightyOne?
Replies: 2
Views: 6991

Re: Can this game be played on EightyOne?

mrtinb wrote: Tue Feb 11, 2020 10:07 amYou need to enable RAM in 8k - 16k area as well.
This is already enabled by default. I just get a blank screen.