Search found 187 matches

by bola_dor
Wed Aug 05, 2020 12:15 am
Forum: Hardware
Topic: No video output from my TS1500
Replies: 15
Views: 3640

Re: No video output from my TS1500

I guess any oscilloscope in the usd375 range as that will do the job :lol:..
I wonder if there is a Chinese model in the usd 50 to 100 range .. it could be even £100 is capable enough?
by bola_dor
Fri Jul 31, 2020 1:39 am
Forum: Hardware
Topic: Ferranti ULA 5C114E info?
Replies: 25
Views: 7472

Re: Ferranti ULA 5C114E info?

BTW the source of the info on the 5C114 is here . Mark I followed that post but couldn't find the test they used.. there lost of broken links.. I will test one of then on my machines.. that have PAL crystals but may be thebTV can see something on RFvor on composite.. If you konw any test to perform...
by bola_dor
Thu Jul 30, 2020 3:32 pm
Forum: Hardware
Topic: Ferranti ULA 5C114E info?
Replies: 25
Views: 7472

Re: Ferranti ULA 5C114E info?

Hi. I came across all this Ferranti ULA 5C114E dated 8344.. Would it be safe to test one of these ULA on my CZ spectrum clones? (I don't have any of these last plus models) See here . So going on that, I don’t think you will do any damage. But the 5C ULA chips have less compatible DRAM timing compa...
by bola_dor
Thu Jul 30, 2020 2:24 am
Forum: Hardware
Topic: Ferranti ULA 5C114E info?
Replies: 25
Views: 7472

Ferranti ULA 5C114E info?

Hi. I came across all this Ferranti ULA 5C114E dated 8344.. 20200729_211201.jpg These are related to de Czerweny Factory that made several spectrum clones at that time. First ones named CZ2000 had an ISSUE 6A board. Later "CZ Spectrum" model had a different case with same keyboard and rubber membran...
by bola_dor
Wed Jul 29, 2020 5:42 pm
Forum: Hardware
Topic: CZ1500 ( TS1500 ) composite video mod done
Replies: 7
Views: 2856

Re: CZ1500 ( TS1500 ) composite video mod done

20200728_011215.jpg
Bottom view.
That filter in the corner prevents it to work if you want to use the origuinal output.. and the board is tightly soldered to the box at those four points..
by bola_dor
Tue Jul 28, 2020 9:09 pm
Forum: Hardware
Topic: CZ1500 ( TS1500 ) composite video mod done
Replies: 7
Views: 2856

CZ1500 ( TS1500 ) composite video mod done

Ok this CZ1500 is a rebranded argentinian TS1500 runing at 50Hz.. . I've found at least 2 variants in the 1500 main board and at least three variants in RF modulator.. this I have doesn't have any component attached directly to the board inside the modulator box. In fact the modulator has its own me...
by bola_dor
Mon Jul 27, 2020 7:50 pm
Forum: Hardware
Topic: Will using a mono cable in a stereo line-out cause problems with LOAD?
Replies: 3
Views: 473

Re: Will using a mono cable in a stereo line-out cause problems with LOAD?

Today has been my first try at saving and loading programs from tape. It has been quite an adventure! I have been unable to load programs from a newer cassette player which I believe has a stereo line-out. I'm guessing that this problem may have to do with the player trying to output two channels o...
by bola_dor
Mon Jul 27, 2020 4:59 am
Forum: Hardware
Topic: OUT & vertical sync timing
Replies: 5
Views: 1031

Re: OUT & vertical sync timing

Perhaps someone at the software or development subforum may help.
I saw you at the Facebook group but I haven't much experience in machine code.. :?
by bola_dor
Mon Jul 27, 2020 4:31 am
Forum: Hardware
Topic: No video output from my TS1500
Replies: 15
Views: 3640

Re: No video output from my TS1500

I don't have a TS1500 but I suspect the troubleshooting will be similar to the Ts1000 and Z81 Cheers, Matthew Yes but RAM is similar to the Spectrum 's lower RAM . So you have to check thre different voltages at 4116 ICs and the 12v rail.. I have a 1500 version with a different RAM. https://www.sin...
by bola_dor
Sat Jul 25, 2020 7:55 am
Forum: Hardware
Topic: CZ1500/TS1500 Board and electrolytic miss marking
Replies: 11
Views: 1120

Re: CZ1500/TS1500 Board and electrolytic miss marking

64 means that bit 6 is set on the “ULAs” input port, which means that the “ULA” is reading the 50/60Hz pin as set for 50Hz. The same as a U.K. ZX81. Hence the code in the ROM is using 50Hz timing. If bit 6 was clear (logic low) then it would indicate 60Hz and the code in the ROM would use 60Hz timi...